SalesEQ - Delayed webhooks – Incident details

Cloudflare → Cloudflare Sites and Services → Network experiencing degraded performance

Delayed webhooks

Resolved
Degraded performance
Started about 1 month agoLasted 23 minutes

Affected

Resend → Email Events

Degraded performance from 8:34 PM to 8:38 PM, Operational from 8:38 PM to 8:57 PM

Updates
  • Resolved
    UTC
    Resolved

    We have resolved the underlying issue, and all the affected webhooks have been sent.

  • Monitoring
    UTC
    Monitoring

    Affected webhooks are now being sent. We expect the affected webhooks to be sent within the next 20 minutes.

    No webhooks were lost.

  • Identified
    UTC
    Identified

    We have identified the issue and we are working on a fix now.

  • Update
    UTC
    Update

    We have identified that email events are being updated correctly in the dashboard, but webhook sending is delayed. The team is still investigating.

  • Investigating
    UTC
    Investigating

    We are currently investigating increased latency in email events. Emails are being sent normally without any delays, but their respective statuses are taking longer to appear in the dashboard or via webhooks.

    Email sending is not affected.